Skip to main content

Reply to this post | Go Back
View Post [edit]

Poster: tfmorris Date: Jan 18, 2014 11:25am
Forum: texts Subject: MARC download fails intermittently

Depending on what host I get redirected to, I'm getting different results when attempting to dereference this URL:
http://archive.org/download/cu31924022008746/cu31924022008746_archive_marc.xml

This works:
http://ia600506.us.archive.org/fetchmarc.php?path=%2F2%2Fitems%2Fcu31924022008746%2Fcu31924022008746_marc.xml
but this fails:
http://ia700506.us.archive.org/fetchmarc.php?path=%2F2%2Fitems%2Fcu31924022008746%2Fcu31924022008746_marc.xml

and returns the following as content:

file "/2/items/cu31924022008746/cu31924022008746_marc.xml" not found
Terms of Use (10 Mar 2001)

which my XML parser can't understand for some reason. :-)

In addition to the inconsistency across the cluster, it also seems like the failure isn't returning an HTTP error status.

Is there a better place than the forums to report bugs like this?

Tom

Reply to this post
Reply [edit]

Poster: Jeff Kaplan Date: Jan 18, 2014 11:56am
Forum: texts Subject: Re: MARC download fails intermittently

fwiwi, i'm not able to duplicate the problem. boh links work identically fine for me.

info@archive.org allows us to keep better track of them. thanks.

This post was modified by Jeff Kaplan on 2014-01-18 19:56:03

Reply to this post
Reply [edit]

Poster: tfmorris Date: Jan 18, 2014 12:07pm
Forum: texts Subject: Re: MARC download fails intermittently

OK, so I guess the intermittent failures aren't actually tied to the host and that was just a coincidence. Presumably these File Not Found failures get logged someplace. Perhaps that will provide more info on what happened.

I'll try email for future problem reports.